Client backward compat with server

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Client backward compat with server

Irfan Hamid
Hi,

We are running 3.4.6 servers and the same client. However, I'm running up
against a bug (ZOOKEEPER-2375) which is fixed in 3.4.9, and I was wondering
if I can just update the client (a much easier proposition) and keep
running 3.4.6 as the quorum servers.

Regards,
Irfan.
Reply | Threaded
Open this post in threaded view
|

Re: Client backward compat with server

hanm
Releases with fixed major.minor version are backward compatible - so 3.4.9
is backward compatible with 3.4.6 (major=3, minor=4 in this case.).
Backward compatible means two different versions of client and server can
be mixed - in your case it could be 3.4.9 client with 3.4.6 server. So this
should work, if not it could be a bug, as it breaks the compatibility
guarantee we provided. See
https://cwiki.apache.org/confluence/display/ZOOKEEPER/ReleaseManagement for
more details on compatibility promise.

On Mon, Mar 27, 2017 at 10:05 AM, Irfan Hamid <[hidden email]> wrote:

> Hi,
>
> We are running 3.4.6 servers and the same client. However, I'm running up
> against a bug (ZOOKEEPER-2375) which is fixed in 3.4.9, and I was wondering
> if I can just update the client (a much easier proposition) and keep
> running 3.4.6 as the quorum servers.
>
> Regards,
> Irfan.
>



--
Cheers
Michael.